Question for those HELO users

Discussion in 'General Rebuildable Discussion (RTA/RBA/RDA)' started by bucksfan1976, Jan 11, 2019.

  1. bucksfan1976

    bucksfan1976 New Member

    Blog Posts:
    0
    Joined:
    Feb 26, 2018
    Messages:
    66
    So I have Helo RTA's , Im not getting Vape Lock, but after taking several hits, it starts to burn, If I give it a second for the juice to catch up im fine for a couple more hits. Then its starts again. Im using a flat wire, with a inner diameter of 3.0. Im kinda lost because i tried adjusting cotton and that didnt help. Could it be i need a larger inner diameter coil? bling.jpg
     
  2. PaulS

    PaulS Gold Contributor Member For 3 Years

    Blog Posts:
    0
    Joined:
    Aug 5, 2015
    Messages:
    2,348
    I'm using a fused clapton, 3. mm and never get a dry hit. It is likely your cotton. You need to thin out the cotton more and allow capillary action to the coil.
     
  3. bucksfan1976

    bucksfan1976 New Member

    Blog Posts:
    0
    Joined:
    Feb 26, 2018
    Messages:
    66
    hmmm maybe wire type then? this is what im using , well something like it
     

    Attached Files:

  4. jwill

    jwill The Great King of Nothing VU Vendor VU Donator Gold Contributor VU Challenge Team Reddit Exile

    Blog Posts:
    0
    Joined:
    Feb 25, 2018
    Messages:
    4,597
    The Helos from my experience is not a dry hitter nor is it leaky.Those coils should be fine unless you are just railing it at 300watts @PaulS provided the right answer. Thin the tips and dont stuff the wicking channels. I use SSFC w/ 3.5 mm ID and they just work.
     
    PaulS likes this.

Share This Page

Close This Message